Attachment Previews Not Showing

Incident Report for MyMediabox

Postmortem

Incident Update: Data Loss

Update: File Recovery Post-Outage

We regret to inform you that some files uploaded during the outage on 10/14 could not be recovered. We understand the inconvenience this may cause and are committed to supporting you.

Steps to Reupload Affected Files:

  • Open your project and navigate to the attachments tab.
  • Select the upload icon to re-upload your files.

If the upload button is unavailable, it could mean your current role settings restrict access. In such cases, please reach out to MMB support or your Lead Reviewer with the project number and pertinent file details.

Your understanding and cooperation are highly valued as we work to ensure a smooth experience. Please don't hesitate to contact support if you need assistance.

Posted Oct 15, 2025 - 17:03 UTC

Resolved

Incident is resolved.
Tuesday, 14th of October at 11:00 UTC the primary storage cluster failed. Resolution was to revert to a backup.
Some data loss is possible.
Post mortem for the incident to follow.
Posted Oct 14, 2025 - 17:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Some attachments uploaded between 11:00 - 14:00 UTC might not be available and data might be lost.
Posted Oct 14, 2025 - 15:24 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 14, 2025 - 14:00 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 14, 2025 - 11:00 UTC
This incident affected: Product Approvals (PA).